Username
Password

Wired & Wireless

Le reti: consigli, cosa fare in caso di problemi
Saturday, 2 December 2006, 13:46
vic20
 
 Messaggi: n/a
Exclamation

configurazione zixel 660hw-61 e ftp


salve a tutti

n.b. quando facevo queste cose
1) i programmi erano su cassetta
2)il mouse aveva paura del gatto, due palle e non una
3)l'ibm faceva armadi pieni di lucine strane
4)il caricamento avveniva con incomprensibili caratteri ascii a schermo

quindi abbiate pietà rendetemi le cose molto semplici.

vi illustro la ferraglia (HW):

router zyxel prestige 660hw-61
ip pubblico dinamico (es.:82.84.256.238)
ip privato 192.168.1.1

portatile asus wireless
ip privato 192.168.1.40
stessa subnet
subnet 255.255.255.0

portatile asus wireless - win xp sp2
ip privato 192.168.1.40
stessa subnet


ftp - lan server drive samba 3,5" in ascolto su porta 21
ip privato 192.168.1.90
stessa subnet

se faccio
http://192.168.1.1 vedo il web configurator del prestige
http://82.84.256.238 vedo il web configurator del prestige
http://192.168.1.90 vedo il web configurator del lan-drive samba
ftp://192.168.1.90 vedo l'ftp server samba

e sin qua tutto bene
il problema è che
ftp://82.84.256.238 non funziona (niente samba, ne macarena)

so che devo fare qcs col nat e col firewall, ergo ho fatto:

1)
nat-sua-edit-in.port:21,end.port:21,ip 192.168.1.90
2)
firewall-rules-add-wan to lan- anysource,any destination, port 20,21,forward,enable.

MA PERCHE' NON FUNZIONA??

sto iniziando a provare un vago senso di disperazione

aiutatemi prima che mi si stringa il cavo cross al collo..
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 14:36
SataNik
 Raffaele Fazio
 Staff
 
L'avatar di  SataNik
 
 Località: Serrastretta (CZ)
 Messaggi: 10,655

Io ho lo stesso router e non ho problemi.
Intanto dovresti vedere se dall'esterno riesci a connetterti al .90 semplicemente con un telnet ippubblico 21
Gia' se vedi il messaggio di welcome e' un buon segno.
Se si connette prova a fare una connessione in modalità PASV o non PASV e vedi che succede.
Se non si connette significa che il problema sta sul router.
Prova e facci sapere. Poi continuiamo
__________________


"Se il risultato conferma le ipotesi, allora hai appena fatto una misura, se il risultato è contrario alle ipotesi, allora hai fatto una scoperta."
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 15:01
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 55
 Messaggi: 4,519

Ma la prova di collegamento l'hai fatta dall'esterno (Internet) o dall'interno (LAN)? Perchè se l'hai fatta dall'interno è normale che non funzioni.

Poi analizzando gli ultimi due punti, direi che c'e' un'incongruenza tra le impostazioni della sezione NAT e quelle della sezione Firewall.

Sul NAT apri la sola porta 21 mentre sul Firewall apri la 20 e la 21, poi sempre sul firewall, al posto di any destination dovresti metterci l'IP del Server FTP come hai fatto nella sezione NAT.
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 16:55
vic20
 
 Messaggi: n/a
Red face

prima di tutto grazie per l'aiuto e la comprensione.
dunque:

Quote:
Originariamente inviato da Jarod
Ma la prova di collegamento l'hai fatta dall'esterno (Internet) o dall'interno (LAN)? Perchè se l'hai fatta dall'interno è normale che non funzioni.
.

ecco, questa era una cosa che non sapevo. (quanto mi sento arcaico.. sigh)

Quote:
Originariamente inviato da Jarod
Sul NAT apri la sola porta 21 mentre sul Firewall apri la 20 e la 21, poi sempre sul firewall, al posto di any destination dovresti metterci l'IP del Server FTP come hai fatto nella sezione NAT.

fatto anche questo.

tuttavia, quando mi collego dall'esterno della lan,
http://[ippubblico]
mi da come risposta "this feature i protected on prestige [..]" e qs mi va bene.

telnet [ippubblico] 23
mi da accesso al router
richiesta password e quant'altro (alleluja) e anche qs mi va bene

ma ancora
telnet [ippubblico] 21 non mi da risposta
ftp://[ippubblico] nisba
http://[ippubblico]:porta non funge con nessuna porta da 01 a 50

e quindi niente ftp.
e dire che invece dall'interno della lan
ftp://192.168.1.90
e
http://192.168.1.90 (samba configurator)
vanno benissimo.

cos'è che manca?
lo scorsoio del cavo cross si stringe
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 17:02
Duilio
 Khn'nr
 Stuff
 
L'avatar di  Duilio
 
 Località: Tarnax IV
 Età: 54
 Messaggi: 27,893

E' una cosa abbastanza normale, da noi si usa un dns interno che rimappa le richieste all' ip pubblico sull' ip locale della macchina che viene cosi' scomodata per nome.

Ora mettere in piedi un dns apposta mi sembra eccessivo. C' e' qualche fortunato che lo tiene integrato nel router...


C' e' un altro problema con gli accesi dall' interno a risorse interne: quando fai il port forwading cambiando il valore della porta, so' volatili pe' diabetici.

Esempio se la 80 di una macchina locale viene esposta su ip pubblico come porta 8080.... non puoi mimare la ricerca come se venisse dall' esterno.
Il dns ti rende l' ip giusto ma devi cercare il servizio sulla porta locale.

Di solito metto un pc fuori, da qualche parte, lo piloto in remoto con vnc e testo i servizi da li' verso di me.
__________________

Uccidete pure me, ma l'idea che è in me non l'ucciderete mai

-
"Non consolarmi della morte", a Ulisse replicava il Pelìde.
"Io pria torrei servir bifolco per mercede, a cui scarso e vil cibo difendesse i giorni,
che del Mondo defunto aver l'impero."
-
tutto il klan deve rendere conto solo a Dio, mica agli elettori e alla giustizia [taunus 20:10]
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 17:30
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 55
 Messaggi: 4,519

Quote:
Originariamente inviato da vic20
ma ancora
telnet [ippubblico] 21 non mi da risposta
ftp://[ippubblico] nisba
http://[ippubblico]:porta non funge con nessuna porta da 01 a 50

e quindi niente ftp.
e dire che invece dall'interno della lan
ftp://192.168.1.90
e
http://192.168.1.90 (samba configurator)
vanno benissimo.

cos'è che manca?
lo scorsoio del cavo cross si stringe
Beh, intanto il secondo link ovvero http://[ippubblico], non potrà mai funzionare in quanto non hai effettuato il port forwarding della porta TCP 80 (e se l'hai fatto non ce l'hai detto).

Poi per il server FTP ci sarebbe un'altra cosa da sapere: In che modalità è impostato il Server? Attiva o Passiva?

Non sarebbe male poter vedere anche le schermate di configurazione del router (NAT e Firewall), per vedere se i settaggi sono corretti.
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 19:26
vic20
 
 Messaggi: n/a

Quote:
Non sarebbe male poter vedere anche le schermate di configurazione del router (NAT e Firewall), per vedere se i settaggi sono corretti.

sono (p)(e)(r)(f)(e)(t)(t)(a)(m)(e)(n)(t)(e) d'accordo.

ehm... com'è che si fa?

(nel senso: l'upload delle immagini .jpg non mi funziona..)
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 19:54
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 55
 Messaggi: 4,519

Puoi caricare le immagini su ImageShack (gratuito) e poi metti i link qui sul forum (cliccando sull'icona "Inserisci Immagine").
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Rispondi Invia Nuova Discussione


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 visitatori)
 

Thread già visto da:
Andrea72, taunus, SataNik, Pocket, ggigi99, lurker1, SanK, revenge, Morpheus, Jarod, Duilio, S71ng, paopao, gattonero, Lutero, kaos
Strumenti Discussione Cerca in questa Discussione
Cerca in questa Discussione:

Ricerca Avanzata
Modalità Visualizzazione

top Regole di scrittura
Tu non puoi inserire messaggi
Tu non puoi rispondere ai messaggi
Tu non puoi inviare allegati
Tu non puoi modificare i tuoi messaggi

codice vB è Attivo
Smilies è Attivo
[IMG] il codice è Attivo
Il codice HTML è Attivo

Se hai problemi, contattaci


Visite Totali Posts: 67.352.337
Tutti gli Orari sono GMT +1. Attualmente sono le 21:43.

iGroup Black
Powered by vBulletin Versione 3.5.6
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Traduzione italiana a cura di: Enzo-Staff-VbulletinItalia.it
 
2000, 2012 © Visiva Group