Username
Password

Video Tutorial

Vuoi diventare un mago del computer? segui le migliori Video Guide del Web
Rispondi Invia Nuova Discussione 
Wednesday, 1 November 2006, 13:25
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 58
 Messaggi: 4,520

Re: Tutorial Video: Installare e Configurare una VPN con OpenVPN


Beh per raggiungerlo tramite VPN è indispensabile installare e configurare OpenVPN anche sul secondo client, oltre che abilitare la direttiva Client-to-Client sul file di configurazione del Server.
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Saturday, 4 November 2006, 18:45
nimda
 
 Messaggi: n/a

Innanzitutto grazie e complimenti per l'ottimo tutorial.
Seguendolo sono riuscito a configurare sia un server che un client.
Vorrei se fosse possibile applicare tale soluzione verificandone le performance per collegare in vpn anche amici utenti di fastweb con i quali gioco in multiplayer e che attualmente costringono il nostro gruppo ad usare hamachi (non avedno ip pubblico).

Abbiamo fatto un tentativo ma ovviamente la classe di ip del bridge creato dall'utente fastweb non equivale a quella della mia lan (sulla quale ho il server funzionante e settato con la config del tutorial).. e presumo sia questo il motivo per il quale non ha funzionato

Sapreste mica dirmi come fare per configurare client e server ?
    Rispondi Citando Rispondi
Saturday, 4 November 2006, 19:13
JeanBabalan
 Rico
 Staff
 
L'avatar di  JeanBabalan
 
 Località: NY Zoo
 Età: 49
 Messaggi: 7,070

temo che le vpn con le policy di sicurezza di fastweb facciano a pugni...

fino a poco tempo fa l'utenza residenziale non poteve configurare alcun tipo di vpn, oggi non so.....
__________________
nihil humanum a me alienum puto
    Rispondi Citando Rispondi
Sunday, 5 November 2006, 11:55
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 58
 Messaggi: 4,520

Quote:
Originariamente inviato da nimda
Abbiamo fatto un tentativo ma ovviamente la classe di ip del bridge creato dall'utente fastweb non equivale a quella della mia lan (sulla quale ho il server funzionante e settato con la config del tutorial).. e presumo sia questo il motivo per il quale non ha funzionato

Sapreste mica dirmi come fare per configurare client e server ?
Premesso che non ho alcuna esperienza sulle problematiche della rete FastWeb (nella mia regione non è ancora arrivata), sono sicuro che il problema è quello che ti ha già indicato JeanBabalan.

Da una veloce ricerca in rete, ho letto che i loro firewall in pratica non lasciano passare quasi nulla e più passa il tempo e più la situazione peggiora per gli utenti FW.

Ho letto che molte porte sono bloccate così come vengono segati diversi protocolli. Se proprio ti vuoi divertire potresti provare ad utilizzare numeri di porta diversi da quella predefinita e proverei anche ad utilizzare il protocollo TCP invece dell'UDP.
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Sunday, 5 November 2006, 12:50
nimda
 
 Messaggi: n/a

Quote:
Originariamente inviato da Jarod
Premesso che non ho alcuna esperienza sulle problematiche della rete FastWeb (nella mia regione non è ancora arrivata), sono sicuro che il problema è quello che ti ha già indicato JeanBabalan.

Da una veloce ricerca in rete, ho letto che i loro firewall in pratica non lasciano passare quasi nulla e più passa il tempo e più la situazione peggiora per gli utenti FW.

Ho letto che molte porte sono bloccate così come vengono segati diversi protocolli. Se proprio ti vuoi divertire potresti provare ad utilizzare numeri di porta diversi da quella predefinita e proverei anche ad utilizzare il protocollo TCP invece dell'UDP.

Premetto anche io una cosa .. di reti non ne so tanto giusto per inquadrare il mio profilo e non farti dar per scontato nulla

Detto ciò, scusa, in che senso numeri di porta diversi .. la condizione per la quale server e client di openvpn funzionino da quanto dici è quella di avere di partenza i due bridge server e client (nel caso di specie), configurati con la stessa classe di Ip a meno che il client non si connetta direttamente con modem (ma non è il caso di FastWeb)

Gli utenti di fastweb a quanto pare invece hanno classi diverse dalla canonica 192.x.x.x ed è impercorribile la strada eventuale di allineare tutti gli altri user normali visto il numero (ndr e non ultimo il profilo di conoscenza informatica di taluni che fan fatica a fare un portforwarding sul loro router ancorchè seguiti passo passo ) alla classe di fastweb.

Un'idea che mi è venuta, ma magari sto dicendo una boiata, è quella di provare a mettere un router dietro al router di fastweb in modo da creare una sottorete canonica 192.x.x.x. Qui ci si scontrerebbe col fatto che alcuni non posseggono un router e che possano anche non essere disposti a prenderlo.
Mi domandavo quindi se non fosse possibile risolver il problema della classe in altro modo: (ecco che sparo un'altra boiata) esistono router virtuali o escamotage fruibili allo scopo ??

Grazie anticipatamente per la pazienza
    Rispondi Citando Rispondi
Sunday, 5 November 2006, 20:00
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 58
 Messaggi: 4,520

Scusa nimda ma fammi capire una cosa:

La connessione VPN tra il Client su rete FastWeb ed il Server viene stabilita oppure no? e se non viene stabilita, che messaggi di errore vengono riportati nei file di log di client e server?

Tieni presente che i client FW all'esterno (quindi anche dal Server OpenVPN) vengono visti comunque con un IP pubblico. Se ti guardi il file di log delle connessioni presente sul server, noterai che l'IP dei Client che vi si connettono NON è quello privato ma quello pubblico. Di conseguenza se la connessione non viene stabilita, mi sembra ovvio che il problema NON è la differente classe di IP privati tra client e server. Quello semmai è un problema successivo ma la connessione deve avvenire comunque.

Per risolvere il problema della differente classe di IP tra Client e Server invece è necessario configurare OpenVPN in modalità Routed e non Bridged.
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 12:15
nico76pro_54
 
 Messaggi: n/a

Innanzi tutto compliementi per il tutorial video!

Vi propongo in mio problema:

server: openVPN installato su una macchina Ipcop 1.4.11 scheda green 192.168.10.x ip dinamico Dyndns e RED su Modem Router il tutto funzionante

client: WinXP con adsl via modem usb con installato openVPN GUI stabilisco la connessione, il problema è che mi viene assegnato un ip 10.10.10.x (che ho impostto si ipcop) e non riesco a fare il bridge tra la connessione adsl e openvpn (come nel video) e se faccio il bridge tra openvnp e lan (che sul client non è installata) dà errori nella connessione...

come posso risolvere il problema? una rete anche sul client in modo da riuscire a fare il bridge? - premetto che dal client riesco a vedere ipcop!

grazie!
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 13:16
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 58
 Messaggi: 4,520

La risposta alla tua domanda è in questo passaggio del mio Thread:

Quote:
Originariamente inviato da Jarod
Nel video sia il Server che il Client sono "nattati", ovvero stanno dietro ad un Router. Lato Server ho dovuto effettuare il Port Forwarding della porta UDP 1194 verso l'indirizzo IP del computer che funge da Server VPN e creare il bridging. Lato Client invece è bastato mettere in Bridging la connessione LAN con quella installata da OpenVPN ed assegnare alla connessione Bridged gli stessi parametri della connessione LAN originaria. Se sul Client o sul Server si utilizza un modem invece che un router, allora non è necessario creare il Bridge, ma è indispensabile disabilitare tutte le connessioni di rete non necessarie (quest'ultima operazione va' fatta anche su configurazioni Bridged).
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 13:36
nico76pro_54
 
 Messaggi: n/a

ok disinstallato la scheda di rete sul client, pingo il server mi risponde, pingo altri pc nada! devo fare anche un port forwarding sul firewall?
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 13:52
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 58
 Messaggi: 4,520

Scusa ma a questo punto non ho capito esattamente qual'e' il tuo problema, potresti essere più chiaro?
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 13:59
nico76pro_54
 
 Messaggi: n/a

il problema è che non è cambiato nulla! ho disabilitato la scheda di rete ma vede solo e sempre il server ipcop della rete e nessun pc!!
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 14:00
nico76pro_54
 
 Messaggi: n/a

provo a riguardarmi il tutorial video...
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 14:05
Jarod
 Giancarlo
 Staff
 
L'avatar di  Jarod
 
 Località: Karalis
 Età: 58
 Messaggi: 4,520

Accertati che lato Server sia abilitata la direttiva Client-to-Client.
__________________
Meglio tacere e passare per idiota che parlare e dissipare ogni dubbio. (Abraham Lincoln)
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 14:07
nico76pro_54
 
 Messaggi: n/a

il problema è nell'IP he mi assegna OpenVPN sul client, come faccio a cambiarlo senza il bridge?
    Rispondi Citando Rispondi
Saturday, 2 December 2006, 14:08
nico76pro_54
 
 Messaggi: n/a

sul server ho installato OpenVPN seguento le istruzioni da www.zerina.de roadwarrior
    Rispondi Citando Rispondi
Rispondi Invia Nuova Discussione


Utenti attualmente attivi che stanno leggendo questa discussione: 1 (0 utenti e 1 visitatori)
 

Thread già visto da:
SkyDiver, C0m4nch3, BigC, microzott, Andrea72, elba, taunus, SataNik, lazio74, JeanBabalan, Galloper, Pocket, SilBerg, ggigi99, DDAAXX, Duke Nukem, glaio, pennabianca, SkidArh+, giskard, Moskitos384, OldSchool, Claude, Harley, MovX, brun, ElettroGigio, 3mendo, Breakbll, Carambola, ale105, pavel, indio, Jaco, zompafosso, athlon, Morpheus, applamosca, M3rcur10, lurker1, XoTho, TrentaCarrini, lutra, RomeoKnight, SanK, Bati®, Ampexv, foul64, revenge, paco, Clipboard, verbatim, elcobra, Jarod, gattonero, Duilio, Carson, Tideglo, JoeBar, palin, Beppe, Valentino28, Th3Condor, Scarpetta, lupic, ERBA_CATTIVA, S71ng, paopao, seepo, Overhauser, Ssnake, Byte01, lentz, kaos, anita, BRAVO 2, usamakey, Sberla80, samdolgoff, bruno1, SatRider, cappadonnaa, cicciocant, Mr. 'T', Foxes, Blackwolf, Bramins, Svirgoli, ibby, Taglioecucito, GiNo, borgobuono, BRICO, alexone74, Skull, virtualdj, targetprice, peppiniello13, helpsearcher79, raulduke84, ale82x, SilverFox, titicaca, Garret, atletico, satanazzo, Neles, FelixModena, zisolord, tenzen, cicciored, blakko86, flavm, ValeriOoz, jeegset, tecnoware, totino, alex4988, enniorob, atrebil, s.coli, Attilio, ericilrosso, criscanz, vinello, CORTOilMALTESE, venezia79, Strangy, fsperandeo, gufo73, ivanmau, maranand, rachel, superjv, Diabolico, arllappa, egcfer, mcqueen, davide72, Fabry5005, Macintosh, webmuvi, Pepito Sbazzeguti, Luther71, shaba, Slepland, Mig, jtd, dect, tr4ding, bubbinho, darhom, wdevice, ildrk, Musakdege, laiuno, MimmoMic, LewMl, WepoKn
Strumenti Discussione Cerca in questa Discussione
Cerca in questa Discussione:

Ricerca Avanzata
Modalità Visualizzazione

top Regole di scrittura
Tu non puoi inserire messaggi
Tu non puoi rispondere ai messaggi
Tu non puoi inviare allegati
Tu non puoi modificare i tuoi messaggi

codice vB è Attivo
Smilies è Attivo
[IMG] il codice è Attivo
Il codice HTML è Attivo

Se hai problemi, contattaci


Visite Totali Posts: 97.168.447
Tutti gli Orari sono GMT +1. Attualmente sono le 05:17.

iGroup Black
Powered by vBulletin Versione 3.5.6
Copyright ©2000 - 2021, Jelsoft Enterprises Ltd.
Traduzione italiana a cura di: Enzo-Staff-VbulletinItalia.it
 
2000, 2012 © Visiva Group